Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.


    *** ERROR: Expected ';' here: mode=norma ..
    *** ERROR: Expected ';' here: mode=norma ..
    *** ERROR: Expected ';' here: mode=norma ..

    These error occurs when launching 0.24.10 version after 0.25 has been launched.
    Under .klayout dir, klayoutrc filevseems to be causing the errors as there was some difference between new version and old one's.

    How to avoid those error messages?
    Appreciate your help here!

    • CommentAuthorMatthias
    • CommentTimeJan 4th 2018

    Hi Sunil,

    once you run 0.25, the configuration will be modified with new features. Backward compatibility is not a scope of the configuration file.

    You can use "-nc" on 0.24.10 to not read the configuration at all - then 0.24.10 won't complain. For batch applications this may be the best option.

    Or you use "-c" to use a different configuration file for different versions. See "klayout -h" for details.