Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorWicky
    • CommentTimeFeb 27th 2017
     
    Fist off, apologies, I'm new to this, may easily be missing something simple.

    I have a huge .oas file, without any external layer table file to go along with it. When I try to load the whole file it eats up all of memory and freezes up my computer until I can end the process. Is there any easy way to get around this?

    There's two way I can think to do this, but am not sure if they're possible. (Or if there's other ways, I'm all ears)
    1) Load the entire file into a cache on the hard drive, instead of loading it all into RAM
    2) Load only specific layers. (I'm only trying to look at one layer, but can find any way to break that out without loading the whole file)

    Thanks for any help :)
    • CommentAuthorMatthias
    • CommentTimeMar 3rd 2017
     

    Hi Wicky,

    Here are some recommendations:

    • Make sure you are using Viewer mode. Edit mode takes much more memory - specifically in case of OASIS.
    • Use Linux with 64bit. That's the platform of choice when it comes to high performance. No freezing then.
    • Use layer mapping (solution 2.). Layers you don't specify in the mapping table won't get read (use Edit/Reader Options and make sure you don't check "Read all other layers").
    • But some memory. You will find commercial tools that support 1.) on the market, but you can buy a lot of memory for what's one their price tag.

    Matthias