Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorallonpa
    • CommentTimeDec 10th 2017
     
    Hi Matthias
    When trying to build new version 0.25 on our Redhat 6 machine, we get the following error message.

    Do you see any solution for that?

    Thanks!
    Allon

    gmake[2]: Entering directory `/tmp/k/build-release/gsi/gsi'
    g++ -c -m64 -pipe -fvisibility=hidden -O2 -D_REENTRANT -Wall -W -pedantic -Woverloaded-virtual -Wsign-promo -Wsynth -Wno-deprecated -Wno-long-long -Wno-strict-aliasing -Wno-deprecated-declarations -fPIC -DHAVE_QTBINDINGS -DHAVE_PYTHON -DHAVE_RUBY -DHAVE_RUBY_VERSION_CODE=10807 -DKLAYOUT_VERSION=0.25 -DKLAYOUT_VERSION_REV= -DKLAYOUT_VERSION_DATE=2017-12-10 -DKLAYOUT_MAJOR_VERSION=0 -DKLAYOUT_MINOR_VERSION=25 -DKLAYOUT_TINY_VERSION=0 -DMAKE_GSI_LIBRARY -DQT_NO_DEBUG -DQT_SCRIPT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/mkspecs/linux-g++-64 -I../../../src/gsi/gsi -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtDesigner -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtCore -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtNetwork -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtGui -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtXml -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtSql -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtScript -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include -I../../../src/tl/tl -I. -I../../../src/gsi/gsi -I. -o gsi.o ../../../src/gsi/gsi/gsi.cc
    g++ -c -m64 -pipe -fvisibility=hidden -O2 -D_REENTRANT -Wall -W -pedantic -Woverloaded-virtual -Wsign-promo -Wsynth -Wno-deprecated -Wno-long-long -Wno-strict-aliasing -Wno-deprecated-declarations -fPIC -DHAVE_QTBINDINGS -DHAVE_PYTHON -DHAVE_RUBY -DHAVE_RUBY_VERSION_CODE=10807 -DKLAYOUT_VERSION=0.25 -DKLAYOUT_VERSION_REV= -DKLAYOUT_VERSION_DATE=2017-12-10 -DKLAYOUT_MAJOR_VERSION=0 -DKLAYOUT_MINOR_VERSION=25 -DKLAYOUT_TINY_VERSION=0 -DMAKE_GSI_LIBRARY -DQT_NO_DEBUG -DQT_SCRIPT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/mkspecs/linux-g++-64 -I../../../src/gsi/gsi -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtDesigner -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtCore -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtNetwork -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtGui -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtXml -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtSql -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtScript -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include -I../../../src/tl/tl -I. -I../../../src/gsi/gsi -I. -o gsiClassBase.o ../../../src/gsi/gsi/gsiClassBase.cc
    g++ -c -m64 -pipe -fvisibility=hidden -O2 -D_REENTRANT -Wall -W -pedantic -Woverloaded-virtual -Wsign-promo -Wsynth -Wno-deprecated -Wno-long-long -Wno-strict-aliasing -Wno-deprecated-declarations -fPIC -DHAVE_QTBINDINGS -DHAVE_PYTHON -DHAVE_RUBY -DHAVE_RUBY_VERSION_CODE=10807 -DKLAYOUT_VERSION=0.25 -DKLAYOUT_VERSION_REV= -DKLAYOUT_VERSION_DATE=2017-12-10 -DKLAYOUT_MAJOR_VERSION=0 -DKLAYOUT_MINOR_VERSION=25 -DKLAYOUT_TINY_VERSION=0 -DMAKE_GSI_LIBRARY -DQT_NO_DEBUG -DQT_SCRIPT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/mkspecs/linux-g++-64 -I../../../src/gsi/gsi -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtDesigner -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtCore -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtNetwork -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtGui -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtXml -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtSql -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtScript -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include -I../../../src/tl/tl -I. -I../../../src/gsi/gsi -I. -o gsiClass.o ../../../src/gsi/gsi/gsiClass.cc
    g++ -c -m64 -pipe -fvisibility=hidden -O2 -D_REENTRANT -Wall -W -pedantic -Woverloaded-virtual -Wsign-promo -Wsynth -Wno-deprecated -Wno-long-long -Wno-strict-aliasing -Wno-deprecated-declarations -fPIC -DHAVE_QTBINDINGS -DHAVE_PYTHON -DHAVE_RUBY -DHAVE_RUBY_VERSION_CODE=10807 -DKLAYOUT_VERSION=0.25 -DKLAYOUT_VERSION_REV= -DKLAYOUT_VERSION_DATE=2017-12-10 -DKLAYOUT_MAJOR_VERSION=0 -DKLAYOUT_MINOR_VERSION=25 -DKLAYOUT_TINY_VERSION=0 -DMAKE_GSI_LIBRARY -DQT_NO_DEBUG -DQT_SCRIPT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/mkspecs/linux-g++-64 -I../../../src/gsi/gsi -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtDesigner -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtCore -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtNetwork -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtGui -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtXml -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtSql -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include/QtScript -I/usr/local/installs/qt-everywhere-opensource-src-4.8.3/include -I../../../src/tl/tl -I. -I../../../src/gsi/gsi -I. -o gsiDeclBasic.o ../../../src/gsi/gsi/gsiDeclBasic.cc
    ../../../src/gsi/gsi/gsiMethodsVar.h: In member function ‘void gsi::ConstMethod0<X, R, F>::call(void*, gsi::SerialArgs&, gsi::SerialArgs&) const [with X = gsi::Value, R = const tl::Variant&, F = gsi::return_by_value]’:
    ../../../src/gsi/gsi/gsiDeclBasic.cc:70: instantiated from here
    ../../../src/gsi/gsi/gsiMethodsVar.h:311: error: no matching function for call to ‘gsi::SerialArgs::write(const tl::Variant&)’
    ../../../src/gsi/gsi/gsiSerialisation.h: At global scope:
    ../../../src/gsi/gsi/gsiSerialisation.h: In instantiation of ‘gsi::adaptor_factory<gsi::var_ref_tag, tl::Variant&>’:
    ../../../src/gsi/gsi/gsiSerialisation.h:1904: instantiated from ‘void gsi::copy_to(gsi::AdaptorBase&, X&, tl::Heap&) [with X = tl::Variant]’
    ../../../src/gsi/gsi/gsiSerialisation.h:522: instantiated from ‘X gsi::SerialArgs::read_impl(const gsi::adaptor_cref_tag&, tl::Heap&) [with X = const tl::Variant&]’
    ../../../src/gsi/gsi/gsiSerialisation.h:210: instantiated from ‘X gsi::SerialArgs::read(tl::Heap&) [with X = const tl::Variant&]’
    ../../../src/gsi/gsi/gsiMethodsVar.h:83: instantiated from ‘void gsi::MethodVoid1<X, A1>::call(void*, gsi::SerialArgs&, gsi::SerialArgs&) const [with X = gsi::Value, A1 = const tl::Variant&]’
    ../../../src/gsi/gsi/gsiDeclBasic.cc:70: instantiated from here
    ../../../src/gsi/gsi/gsiSerialisation.h:1892: error: forming reference to reference type ‘tl::Variant&’
    ../../../src/gsi/gsi/gsiSerialisation.h: In function ‘void gsi::copy_to(gsi::AdaptorBase&, X&, tl::Heap&) [with X = tl::Variant]’:
    ../../../src/gsi/gsi/gsiSerialisation.h:522: instantiated from ‘X gsi::SerialArgs::read_impl(const gsi::adaptor_cref_tag&, tl::Heap&) [with X = const tl::Variant&]’
    ../../../src/gsi/gsi/gsiSerialisation.h:210: instantiated from ‘X gsi::SerialArgs::read(tl::Heap&) [with X = const tl::Variant&]’
    ../../../src/gsi/gsi/gsiMethodsVar.h:83: instantiated from ‘void gsi::MethodVoid1<X, A1>::call(void*, gsi::SerialArgs&, gsi::SerialArgs&) const [with X = gsi::Value, A1 = const tl::Variant&]’
    ../../../src/gsi/gsi/gsiDeclBasic.cc:70: instantiated from here
    ../../../src/gsi/gsi/gsiSerialisation.h:1904: error: ‘get’ is not a member of ‘gsi::adaptor_factory<gsi::var_ref_tag, tl::Variant&>’
    gmake[2]: *** [gsiDeclBasic.o] Error 1
    gmake[2]: Leaving directory `/tmp/k/build-release/gsi/gsi'
    gmake[1]: *** [sub-gsi-make_default] Error 2
    gmake[1]: Leaving directory `/tmp/k/build-release/gsi'
    gmake: *** [sub-gsi-make_default] Error 2
    • CommentAuthorMatthias
    • CommentTimeDec 10th 2017 edited
     

    Hi,

    which gcc are you using?

    Matthias

    • CommentAuthorallonpa
    • CommentTimeDec 17th 2017
     
    Hi Matthias.
    gcc-4.2.0
    Thanks!
    Allon
    • CommentAuthorMatthias
    • CommentTimeDec 17th 2017
     

    Hi Allon,

    do you have a change to try with a more recent version? The oldest one I was testing on is 4.4. Even CentOS 6 comes with that version.

    gcc 4.2 seems not to follow the template type inference rules the newer compilers use.

    Thanks,

    Matthias

    • CommentAuthorallonpa
    • CommentTimeDec 20th 2017
     
    Thanks Mattias. It worked!