"Automatically add other layers" is always working

edited September 2017 in KLayout Support
Hello Matthias-

When starting Klayout, I always get additional layers I do not wish to see in the layer properties window.
That is happening even when I un-check this option in setup menu.

What am I doing wrong?

Thanks, Itamar


  • edited 8:40PM

    Hi Itamar,

    do you automatically load a layer properties file?

    There is a second option to load a layer properties file from a technology. There should be a second flag. Maybe this one is set in the default technology?



  • edited 8:40PM
    Hi Matthias-

    I automatically load a layer file. But I found yesterday that the problem was probably because the automatic lyp file loaded is defined in two different places, Setup-LayerProps & Technology-Default menu. I don't put any file under the specific technology nodes (single lyp file with multiple tabs covers all nodes)
    When openeing new layout which lyp file is being loaded? the one in Setup-LayerProps or the one in Technology-Default?
    Yesterday when I removed one of those the problem was solved.

    One issue I still see and also saw it at a peer's PC:
    When changing the layers (specificallty I was adding gds layer to a group) then saving and overwriting the default lyp file then closing all app windows and re-opening, the lyp is not as I saved it.
    The layer I added is either not in there or it is not inside the group I put it (it went outside of the group to the bottom of list, but you can see it used to be in the group where I put it first because it has the same color/stipple I designated to that group)

    I'm using version 0.24.10

    Thanks, Itamar
  • edited 8:40PM

    Hi Itamar,

    I need to verify this, but in case of two locations I the technology .lyp should win.

    I tried to reproduce the issue you mentioned, but I was not successful so far. Here is what I did:

    • Create a default .lyp file and entered it in Setup/Layer Properties
      ("add other layers" was off)
    • I loaded a layout - this .lyp was shown
    • I added a layer using Edit/Layers/New Layer
    • I assigned some styles to this layer and saved the .lyp file, overwriting the original one
    • If I open a layout again, I see the new layer in the .lyp file

    I also tried with groups as well, but I could not reproduce any odd behaviour. Any ideas?



  • edited 8:40PM
    Hi Matthias-

    Please try the following:
    1. Open your sample.gds (the one used for cross section example) without any lyp. 11 differnt layers (layers 1/0 to 8/1) should appear on the layers panel.
    2. Select first four layers (1/0 , 2/0, 3/0, 3/1) and gather them into a single group
    3. Delete layer 4/0 (or any other layer not in the group defined in #2)
    4. Expand the group created in #2 and select one of the layers under this group
    5. Do "Insert layer Entry" and insert layer 4/0. layer 4/0 will now also appear under this group. Rename this group to "ita"
    6. Save the lyp file you created.
    7. Close Klayout
    8. Restart Klayout and open sample.gds
    9. Open the lyp you saved in #6

    At this stage I am getting two different "ita" groups. The one on top has the four original layers I put there (in step - #2, 1/0 , 2/0, 3/0, 3/1).
    However layers 4/0 is not in the top group. Instead it is in additional group created at the bottom with the same name "ita", but this bottom group only has layer 4/0 in it.

    I hope you can repeat it. Maybe there is a way to send you ppt with snapshots?

    Thanks much, Itamar
Sign In or Register to comment.