Doing Measurements

A measurement can be performed by clicking on the ruler icon in the toolbar and selecting "Ruler" from the drop-down options. Left-click on a point in the layout and then left-click again to specify the second point. A ruler will be shown that indicates the distance measured.

A more convenient way is provided with the single-click measurement ruler. Select "Measure" from the drop-down options of the ruler symbol. In this mode, a single click will set a ruler to the specified position. This feature will look for edges in the vicinity of the ruler and set the ruler to connect the neighboring edges. The ruler is attached perpendicular to the edge next to the initial point.

Rulers can be configured in manifold ways. Use "Rulers And Annotations Setup" in the "Edit" menu to open the ruler configuration dialog. A ruler can be made to snap to edges of objects by selecting "Snap to edge/vertex". Ruler orientations can be constrained by using the "Angle Constraint" options. The number of rulers can be limited using the "Limit number of annotations" setting.

While drawing or moving one point of a ruler, the direction constraint can be overridden with the Shift and Ctrl keys: pressing Shift while moving the mouse will enforce orthogonal constraint, Ctrl will enforce diagonal constraint while pressing both will release any direction constraint.

All rulers can be cleared using the "Clear all rulers" function from the "Edit" menu.

Ruler dragging can be canceled with the "Esc" key or using the "Cancel" function from the "Edit" menu.

Rulers can be moved by selecting "Move" mode with the speedbar buttons in the toolbar or "Move" from the "Mode" submenu in the "Edit" menu. Then left-click and drag the ruler or the ruler end point that should be changed.

Rulers can be deleted selectively by selecting a ruler in "Select" mode and pressing "Delete".

Rulers can be modified in a variety of ways. For example, rulers can be shown as arrows. To edit the properties of a ruler, double-click the ruler or select it and use "Properties" from the "Edit" menu. See Ruler Properties for a description of the properties.

Multiple templates can be configured to be available for rulers. Each template defined will be shown in the "Ruler" mode toolbar button's drop-down menu. If a template is selected, new rulers produced from this template will inherit the template's properties. Templates are managed in the ruler setup page ("Setup" from the "File" menu) or "Ruler And Annotation Setup" from the "Edit" menu.