Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Gui looks ugly

edited April 2018 in KLayout Support
I updated from klayout version 0.24.8 to 0.25.2. I notice the gui does no longer looks nice.
For instance all buttons (select etc.) used to be displayed with slightly rounded corners and now they are square. A screenshot would be nice but seems not possible in this forum.

Any idea what has changed since 0.25 that affects the user interface?
I use CentOS7 with Mate desktop.

Comments

  • edited 5:06PM

    Hi Theo,

    you are always free to file an issue on GitHub at https://github.com/klayoutmatthias/klayout/issues. You can paste screenshots there among many other things.

    I assume in your case Qt picks Windows style. Try "klayout -style CleanLooks" to force Qt using a specific style. Usually there is a tool called "qtconfig" by which you can select the default style Qt applications use. On Gnome, Qt tries to use Gtk+ style and blend into the window manager.

    That's all beyond my influence. The details depend on your installation.

    Matthias

  • edited 5:06PM
    Hi Matthias

    klayout -style CleanLooks works like a charm.
    I also installed qtconfig-qt4 and used it to force CleanLooks as default GUI style.
    Indeed now klayout also works without the -style option.
    It does make me wonder why only klayout does not work out of the box.

    Thanks for your help!
  • edited 5:06PM

    Hi Theo,

    hard to say - I don't do something specific for the style. That's why qtconfig-qt4 is working. It's supposed to act on all Qt applications, so saying it has an effect on KLayout, means KLayout behaves as it's supposed to.

    I know that on Gnome the Qt style detection sometimes fails. But that's related to incompatible Gtk libraries.

    Kind regards,

    Matthias

  • Hi guys,

    'CleanLooks' really is smoother for eyes!

    Are there more styles to choose from?

    Thanks in advance,
    Chris

Sign In or Register to comment.