Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

AutoCAD DXF to Klayout

Hi All,
I want to know how to get my .dxf file to open in K-layout but this error keeps occuring "Coordinate overflow (line = 4727, cell=0) ". I've tried scaling down my features, converting all to features polylines and saving it as other .dxf version that Autocad will allow me. Any help would be brilliant.

Comments

  • Hi,

    AutoCAD is dimensionless, but KLayout assumes micrometers by default. You can change this in "File/Reader Options" on the DXF page under "DXF file unit". The value there is in micrometers. So if your drawing is in nanometers, use a value of 0.001. If the drawing is in millimeters, use 1000.

    There is another setting which you may want to change: the database unit is the internal resolution (a concept inherited from GDS2). Typical values are 0.001 for 1nm.

    If you have set up these values properly, the total area that can be covered by GDS is roughly 1x1m. If you need a bigger area, use a bigger database unit. With a DBU of 0.01 you can cover 10x10m roughly.

    The error you see happens when you exceed that dimension. Please note that scaled cell instances also need to fit into this area before scaling.

    Matthias

  • Hi Mattias,

    I am trying to load a dxf file created in AutoCAD into KLayout, but it seems to be dropping the last coordinate (0.0001) and rounding to 0.001. I have followed how to fix the scaling, etc., resulting from AutoCAD dxf, which has been very helpful. However, I can't seem to figure out how to either recover or open the file so that I do not lose this decimal place.

    Thank you!

  • Hi,

    if you want 0.1nm resolution you have to use a database unit small enough. Go to "File/Reader Options", chose the "DXF" page and enter "0.0001" into "Database unit".

    Matthias

Sign In or Register to comment.