Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

klayout always exits with ERROR: Signal number: 11

edited November 1 in KLayout Support

klayout works like a charm. The only annoyance is that it always complains when I exit. It does not matter if I use the X button or File->Exit

ERROR: Signal number: 11
Address: 0x0
Program Version: KLayout 0.25.2 (2018-03-20 r21e2af2)

Backtrace:
/apps/local/opt/klayout-0.25.2/lib64/libklayout_lay.so.0 +0x291f30 std::_Rb_tree<std::string, std::pair<std::string const, std::pair<lay::SaltModel::Severity, std::string> >, std::_Select1st<std::pair<std::string const, std::pair<lay::SaltModel::Severity, std::string> > >, std::less<std::string>, std::allocator<std::pair<std::string const, std::pair<lay::SaltModel::Severity, std::string> > > >::_M_insert_unique(std::pair<std::string const, std:ERROR: Signal number: 11
Address: 0x0
Program Version: KLayout 0.25.2 (2018-03-20 r21e2af2)

Backtrace:
/apps/local/opt/klayout-0.25.2/lib64/libklayout_lay.so.0 +0x291f30 std::_Rb_tree<std::string, std::pair<std::string const, std::pair<lay::SaltModel::Severity, std::string> >, std::_Select1st<std::pair<std::string const, std::pair<lay::SaltModel::Severity, std::string> > >, std::less<std::string>, std::allocator<std::pair<std::string const, std::pair<lay::SaltModel::Severity, std::string> > > >::_M_insert_unique(std::pair<std::string const, std::pair<lay::SaltModel::Severity, std::string> > const&) [??:?]
/lib64/libpthread.so.0 +0xf5e0 __restore_rt [sigaction.c:?]
:pair<lay::SaltModel::Severity, std::string> > const&) [??:?]
/lib64/libpthread.so.0 +0xf5e0 __restore_rt [sigaction.c:?]

Any clue why I get this? In the terminal it's even colored red to make it look worse.
Before I start the tool I set LD_LIBRARY_PATH.

I also tried it with the latest version:

Warning: Bus::open: Can not get ibus-daemon's address. 
Debug: IBusInputContext::createInputContext: no connection to ibus-daemon 
ERROR: Signal number: 11
Address: 0x0
Program Version: KLayout 0.25.5 (2018-10-20 r30aef18)

Backtrace:
/apps/local/opt/klayout-0.25.5/lib64/klayout/libklayout_lay.so.0 +0x293bb0 lay::enable_signal_handler_gui(bool) [??:?]
/lib64Warning: Bus::open: Can not get ibus-daemon's address. 
Debug: IBusInputContext::createInputContext: no connection to ibus-daemon 
ERROR: Signal number: 11
Address: 0x0
Program Version: KLayout 0.25.5 (2018-10-20 r30aef18)

Backtrace:
/apps/local/opt/klayout-0.25.5/lib64/klayout/libklayout_lay.so.0 +0x293bb0 lay::enable_signal_handler_gui(bool) [??:?]
/lib64/libpthread.so.0 +0xf5e0 __restore_rt [sigaction.c:?]
/libpthread.so.0 +0xf5e0 __restore_rt [sigaction.c:?]

Comments

  • Hi Theo,

    I'm not seeing this. What is the compiler/OS/Python/Ruby/Qt combination you're using?

    You can check, whether that's an issue with a specific macro installed in your system. Please rename your "~/.klayout" folder to something else and try whether you can reproduce the issue.

    Matthias

  • Hi Matthias

    I unset KLAYOUT_PATH and removed ~/.klayout. The issue remains.

    gcc-4.8.5-16.el7.x86_64
    OS=CentOS7
    $ python --version
    Python 2.7.5
    $ ruby --version
    ruby 2.0.0p648 (2015-12-16) [x86_64-linux]
    qt-4.8.5-13.el7.x86_64
    

    Thanks,
    Theo

  • edited November 5

    Hi Theo,

    it looks like this is the default configuration for CentOS7, right? Did you build it yourself, or is that installed from the RPM?

    I don't have CentOS7 on a desktop, but I can run it inside a minimal CentOS7 Docker container.

    This is what works for me:

    docker run -it --rm -e DISPLAY=$DISPLAY -v /tmp/.X11-unix:/tmp/.X11-unix centos:7 bash
    
    In the container:
    $ yum update -y
    $ curl https://www.klayout.org/downloads/CentOS_7/klayout-0.25.5-0.x86_64.rpm >klayout-0.25.5-0.x86_64.rpm
    $ yum install -y klayout-0.25.5-0.x86_64.rpm
    $ export QT_X11_NO_MITSHM=1
    $ klayout
    

    I don't observe segfaults myself. Maybe there is some interaction with some other package or it's a matter of the build process you use (if you build it yourself). Can you describe how you obtained your installation?

    Matthias

  • Hi Matthias

    It's indeed stock CentOS7 no compilation involved.
    I use the rpm, but I unpack it and put it at a central location for all to access (on a NFS share). To double check I now installed it with the rpm, but get the same result

    $ sudo yum install klayout-0.25.5-0.x86_64.rpm
    $ export QT_X11_NO_MITSHM=1
    $ /usr/bin/klayout
    Warning: Bus::open: Can not get ibus-daemon's address. 
    Debug: IBusInputContext::createInputContext: no connection to ibus-daemon 
    ERROR: Signal number: 11
    Address: 0x0
    Program Version: KLayout 0.25.5 (2018-10-20 r30aef18)
    
    Backtrace:
    /usr/lib64/klayout/libklayout_lay.so.0 +0x293bb0 lay::enable_signal_handler_gui(bool) [??:?]
    /lib64/libpthread.so.0 +0xf5e0 __restore_rt [sigaction.c:?]
    

    Also tried as a different user and on a different machine (installed it there). All the same error message.

    Cheers,
    Theo

  • Hi Theo,

    maybe there is a relation to https://www.klayout.de/forum/discussion/comment/4820 ... there seems to be an issue with the input method plugins and KLayout. I'm investigating this.

    Matthias

Sign In or Register to comment.