Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

DRC holes command issue in 0.26 Release

I tried a Linux compliled release and the windows one with the same result:
It works in the previous 0.25.8 release - is there a change required in the drc script?

report("DRC.rpt")
poly = input(1,0)
drc  = poly.holes
drc.output("Holes detected")

Best Regards,
Andy

Comments

  • Hi Andy,

    I see ... unfortunate coincidence. The name "drc" clashes with a variable name used internally inside the DRC framework. This could even be useful, but in your case, assigning the drc variable with something breaks the internals. I wasn't aware of this side effect of Ruby's "instance_eval", but that's how it is.

    Bottom line: please replace "drc" by something else for now. I guess "drc" should better be considered a reserved name. I'm sorry there isn't a better error message.

    Thanks,

    Matthias

  • Hello Matthias,
    thansk for the update - seems obvious. It works now.
    The change was with the latest release, it worked before.
    Glad to see regular updates and very interesting new features (LVS, Antenna ...)

    Thanks for providing such great program.

    Best Regards,
    Andy

Sign In or Register to comment.