Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

klayout 0.26 installation failed on Ubuntu 19.04

edited October 31 in KLayout Support

Hi everyone,
I'm trying to install klayout on my ubuntu 19.04 machine using the .deb package downloaded from the website for Ubuntu 18. I used dpkg (with sudo privileges) to install the package and it stops with an output as seen below :
_$ sudo dpkg -i klayout_0.26-1_amd64.deb
[sudo] password for prithvi:
Selecting previously unselected package klayout.____
(Reading database ... 207250 files and directories currently installed.)
Preparing to unpack klayout_0.26-1_amd64.deb ...
Unpacking klayout (0.26-1) ...
dpkg: dependency problems prevent configuration of klayout:
klayout depends on libpython3.6 (>= 3.6.5); however:
Package libpython3.6 is not installed.

dpkg: error processing package klayout (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-4ubuntu1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
klayout_

I can confirm that I have python3.7 as well as python2.7.16 installed on my ubuntu machine. I can access both the interpreters from the terminal with their appropriate commands.
Also, I have a centos7 machine and i had not issues installing klayout on it. It was very easy.
Please let me know if I can provide more information to help resolve this.
Thanks,
Prithvi

Comments

  • Hello,

    Ubuntu is not on my list of supported platforms. It looks like you need to build it from source. I'm only supporting the LTS releases.

    Matthias

  • Thanks for the information, Matthias! I'll try that asap.

Sign In or Register to comment.