crash in sizing


I'm trying to use klayout 0.26.3 to insert fill using a custom script. When run on a particular design I get a crash with the stack:

0 0x00007ffff5d34ac8 in ?? ()

from /home/tool/klayout/install/0.26.3/lib64/klayout/

1 0x00007ffff5d36c3c in db::instance_iterator::operator++() ()

from /home/tool/klayout/install/0.26.3/lib64/klayout/

2 0x00007ffff5e0d6ac in db::RecursiveShapeIterator::next_shape(db::RecursiveShapeReceiver*) const ()

from /home/tool/klayout/install/0.26.3/lib64/klayout/

3 0x00007ffff6499893 in ?? ()

from /home/tool/klayout/install/0.26.3/lib64/klayout/

4 0x00007ffff648ae7d in db::AsIfFlatRegion::sized(int, int, unsigned int) const () from /home/tool/klayout/install/0.26.3/lib64/klayout/

5 0x00007ffff5e133d9 in db::Region::sized(int, unsigned int) const ()

from /home/tool/klayout/install/0.26.3/lib64/klayout/

I'm not sure if I can release the design data. The script itself is available at Do you have any suggestions on possible causes of this problem?

I will try with the latest klayout once I can get it installed. I'm only two dot releases behind so I don't know that it will change much.



  • With the latest klayout the crash is resolved :)

  • Very good :)

    I tried to correlate your problem with some fixes I made in between. There are some general bug fixes which might explain the problem, but it's hard to say if the issue is really solved.

    Let me know if you encounter the problem again.

    Best regards,


Sign In or Register to comment.