Technology Manager: some technologies base paths are greyed out

Hi Matthias,
I have tried to make a package of what I have developed. I have included a selection of technologies (lyp and lyt files) in salt//tech. When I transfer the whole SALT directory to another computer, everything works, except it keeps some of the technology base paths the exact same string as on my development machine. The ones that are greyed out on my machine adjust nicely to the new base paths, but the ones that are not greyed out remain a 1:1 string copy. This results in the technology not loading in the right lyp file, and some of my ruby macros fail as a result.

Can you tell me what I would have to do to make every defined technology dynamic so that if it is copied onto another machine it would automatically replace the paths ? I haven't tried loading it over a repository yet, but I assume that just copies the files into the same location ? Why are some of the base paths greyed out and some are not ?

Thank you



  • edited December 2020

    Hi Thomas,

    Please take a look into the .lyt files. The "" element should be empty or a relative path. If you specify relative paths, use the forward slash UNIX notation (like "../my_files"). This way, packages will work on Linux and Windows.

    You can also delete the text inside the "Base Path" field in the Technology Manager. This will replace the path by the default one which is the same location as the .lyt file. The "grayed out" base path is the location, KLayout choses in this case.

    Relative paths or the default path is "dynamic" in a sense that when you move the .lyt file, the base path will point to the new location automatically.

    It's somewhat easy to get absolute paths when you use the "Browse" button. Once you have entered an absolute path, it's pinned to this position without moving with the .lyt file.



  • Very good :)

    Edit: corrected a few typos in the text above ...

Sign In or Register to comment.