Changes ?

Hi Matthias,

I use 0.26.8:

(1) I have defined keyboard shortcuts (via Setup => Application => Customize Menu, and separately also via RBA::Application.instance.set_config('key-bindings', @kb_data). It all works, but as soon as I hit apply or OK in the File->Setup, they become unresponsive, even though they are still listed in Setup => Application => Customize Menu. Only RBA::Application.instance.set_config('key-bindings', @kb_data) brings it back to life. Is that a bug ? The File->Setup GUI seems to be the only thing that does it. It is still responsive when I try other things.

(2) Your Macro Development Environment has everything in read-only mode for the last couple of days. It coincides with me installing a salt-mine. Is there a setting somewhere to get it back off read-only ?




  • edited December 2020

    Hi Thomas,

    Regarding 1: "set_config("key-bindings", ...) and using File->Setup should basically do the same. In fact, File-Setup is only a configuration editor. I could not produce this behaviour with a simple test. I wonder what's inside "kb_data". If this somehow induces a syntax error after being passed through the dialog, this could explain the behviour. Are you able to paste the content of this string here?

    Alternatively you can try to check if there is an error message in the log (File/Log Viewer).

    Regarding 2: Packages are read-only in general because I don't want people to modify package code and then complain to the package owners if they break something. Maybe you somehow tricked KLayout into thinking everything is a package now.

    Could you look for "grain.xml" files in the KLayout file tree ("/home/yourself/.klayout" on Linux or "c:\users\yourself\KLayout" on Windows)? These identify packages. There should only be some down in the package cache (below "salt").


  • Ah yes !

    (1) turns out it was a key-binding save file from 2012, I replaced it with something newer, and now everything is ok.

    (2) I moved grain.xml out from under /SALT/, and now I can edit it.

    Thank you !!!

  • Spoke too soon. I don't know what exactly what is going on, but the keyboard shortcuts keep disappearing. I am on 26.9 now. I have attached the kb_data file - as generated in the routine attached. Strangely enough, some of the shortcuts are greyed out right after import (like Esc or CTRL-G). I even tried to place quotation marks around it, before import.

  • @tnoradam

    Thanks for sharing the script.

    Just a question for my understanding: how do you use the script? Do you auto-run it on startup to get your key bindings?



  • No, I run it only once, manually. Also, I looked at it more carefully - there are a few items in the export file that are somewhat obsolete, from a long time ago. I decided to delete everything and recreate it. Seems to be working now. I import it once, and then it remains active.

  • Good to know :)

    I wonder how wrong items can spoil the list, but I'll take a look.


Sign In or Register to comment.