Scaling factor down to 0.00001 level

Hi Matthias,
I wanted to scale an object at a very small level, such as 0.00001, but when I tried scaling it to 0.00015, the result was 0.0002 instead. I also tried enlarging the object by 10 times and then scaling it by a factor of 0.0015, but the output was still not what I wanted.(The same result as the previous attempt)

Is there a limitation to this scaling feature?

Thank you


  • Hi Albert,

    If the scaled shape is with a size that is 1 dub, than this is a normal behavior.

    Following example shows why klayout always gives you a box with 2 unit instead of a 1 unit box when you tried to scale a box to 1 dbu.

    (B) --> (C) : box lower left and upper right corner off grid, snap to nearest grid.

    to avoid this you might need to further reduce the file unit size.

  • edited November 15

    Hi RawrRanger,
    Thanks so much for your explanation.

    On my first attempt, I tried changing my grid setting directly, but it still didn't work. After creating another file with finer database unit, it can work. There is no further issue of scaling feature. Thank you again.


  • @RawrRanger awesome explanation! Thanks :)

Sign In or Register to comment.