Layer Entries in LEF

edited June 2014 in KLayout Support
Hi Matthias,

One more small, but, at my opinion, very important issue I found:
In the last versions of klayout you made very good displaying automatically all numbers of GDS layers that are not covered by .lyp file.
The issue is that it does not for LEF. When I open LEF with some layers that are not described in .lyp, klayout do not draw it.
I need use "Add Other Layer Entries" to make them visible.
Some times I don't know that some new layers are present in LEF and it mekes some problems.
Is it possible to align this with GDS viewer and make it automatically?

Thank you.


  • edited November -1


    I am trying to understand what is going on.

    How do you specify the .lyp file? Are you using "Use default layer properties file" in the setup dialog's "Layer Properties" page? Or are you using a technology binding?

    Do you use "Automatically add all other layers"? Are you saying that option is not working?

    I was not readily able to reproduce the issue so I need some more information.



  • edited June 2014
    1) Yes, I specify .lyp file in "Setup/Layer Properties" dialog in "Use default layer properties file" section.
    2) "Automatically add other layers" option is enabled.
    Looks like this option works partly. It works correctly with GDS and doesn't work with LEF.
    In LEF "other layers" became visible in "Layers" panel only after using "Add Other Entries" option.

    I use the latest klayout version 0.23.4 and run klayout from command line as:
    $> klayout -style windows -c <path>/<tech_name>.layviewrc

    I open both LEF and GDS through "File/Open" or "File/Open LEF" dialog boxes.

    I can send you screenshots if necessary.

    P.S.: Is it correct, that I am not able to open in one klayout window GDS and LEF in different panels?
    When I'm opening LEF, panel with GDS is closed and vice versa.
  • edited November -1

    I guess you mean "Import LEF", not "File/Open LEF", right?

    I'd call the layer properties behaviour a bug. But I can't confirm it right now. I was not able to reproduce that issue with 0.23.4 on Linux right away. The test case I prepared myself was showing the correct behavior - the layers are added if the "Automatically add other layers" is enabled and they are not shown if not.

    Maybe the problem is related to the second question (in P.S.). The import dialog offers different options for the way a layer is imported. If you choose "Import as new layout in new panel" a new tab will open. If you choose "Open as new layout in same panel", it should add the imported LEF layout to the current tab. So basically, if you import LEF on a GDS file, you should have two layouts stacked. In the layer list they should be shown as two layer sets with "@1" and "@2" suffixes indicating that they belong to different layouts. If that is now working than that may indicate some issue with the .lyp file you are using and may explain the behaviour you describe in the first part.



  • edited November -1

    you wrote : I guess you mean "Import LEF", not "File/Open LEF", right?
    And this became a key to all my issues with LEF.

    The problem was that till last time we used 0.21.13 version of KLayout which I installed about 3 years ago.
    And this version doesn't support LEF view. Therefore I installed ruby module for LEF viewing from your site.
    This module runs through "File/Open LEF" dialog.
    Of course, you dont support it :).

    And I missed that new version 0.23.4 I installed contains internal LEF viewer.
    Now I see it works correctly.
    And my other question in parallel discussion concerning LEF syntax is resolved too.

    Sorry for disturbance!
  • edited November -1

    No problem :-)

    Thanks for mentioning this. 0.23.4 also has DEF and should support all layout-related LEF features. If you find an issue there, let me know.

    Best regards,


Sign In or Register to comment.