Layer not shown in palette

edited February 2010 in KLayout Support
Hi Matthias,

Klayout is not showing layers which are present in the GDS when you are specifying a layer set and that these layers are not defined inside even if in the 'Reader Options' we have validated 'Read All Layers'.

If I don't specify a layer set, all the layers are shown in the palette.

I don't know if its a bug or a feature but its really ennoying because I cannot trust klayout when it is showing me in bold the layers present in the layout.

Its not possible to add the layers not present in the set to the palette w/ the same notation like when we don^t have a defined layer set ?



  • edited November -1

    Hi Joaquim,

    In 0.19.3 this can be achieved manually by using "Add other views" from the layer list's context menu. This will add all layers not shown so far using the default colors and stipples. I guess this is what you are looking for.

    In the next release I already added an option to do this automatically (Setup dialog, Application/Layer List section.

    Best regards,


  • edited November -1

    How do I enable the option of color palette when tracing net?
    I'd like to have each net I select with a different color.

    Thanks, Itamar
  • edited November -1

    Use "File/Settings", go to "Other Tools/Net Tracer" and check "Auto-color with palette".


  • edited November -1
    Hi Matthias-

    I was using the editor version and was looking for this option but could not find it.
    Checked the viewer mode and found it.

Sign In or Register to comment.