Slow startup of KLayout


I noticed that the time which KLayout takes to start is over 40 seconds. This happens on Windows 10 since version 0.26.3 (tested with 0.26.4 as well).

I remember older versions take to start less than 10 seconds. Anybody else noticed this?


  • Not me. I'm using KLayout on Windows 10 myself a lot.

    There is one difference which is the OpenSSL library. I packaged a particular OpenSSL library which I selected because it shows better performance in some DNS configurations.

    But OpenSSL normally isn't triggered before you start any network access. So there should not be any difference.

    Another candidate are the macros you have in your user specific configuration. Rename "KLayout" in your home directory to anything differently and check if the startup times get slower. If this is the case, look for macros which might slow down startup.


  • I see 4 seconds for a Win10, 4 core Dell M4800.

    This kind of drag-out might be from long or not-ideally-
    ordered search paths; especially remotely hosted (or
    remotely not-found) path branches may take time to
    "fail out and proceed"?

  • Hi,
    Renaming of the "KLayout" directly solved it. Some further investigation I tried to rename the "klayoutrc" file to init a new one. This speed it up again. My new "klayoutrc" file is 13KB big instead of my old one with 59KB. However it needs still around 10 seconds to start but the root cause is probably that I have in my salt directory many packages with over 1300 files in sum.

    Thanks for the hint. I will cleanup up the "klayoutrc" file from time to time.

  • Very good :)

    But basically I think the problem is something else, not the "klayoutrc" file. At least I'm not aware of settings which may make KLayout slow. Maybe a macro which is run at startup? Or a tech with a big library that is loaded on startup?



Sign In or Register to comment.