Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Change Layer Properties of a Polygon

I have some polygons that ended up on layer 80/0 when they should have been on 80/1. It's from a layout-in-progress under a different tool which I am looking to finish in klayout instead. The correct layertable does not have a 80/0 source, the 80/0 is in error. 80/0 is added to the bottom of the layertable as a "found layer". The problem exists throughout the hierarchy, a global "change 80/0 to 80/1" function would be right on. But polygon by polygon (or selected-set) action would be fine too.

How can I edit the polygon layer assignment? Properties seems not to offer these attributes. Can't find a "move selected to layer" in the menus. Any options besides manual delete and redraw on supported layer?

Comments

  • Hi Jim,

    "move selected to layer" is available: select the objects you want to change, then select the desired layer in the layer list and use "Edit/Selection/Change Layer".

    To globally move a layer, select the layer and use "Edit/Layer/Edit Layer Properties" to rename the layer.

    Regards,

    Matthias

  • I saw this in Windows version 0.26, but it seems to be missing from Ubuntu 0.26.1 menus (see attached screen-grab)? In fact it's missing both options - no Edit>Selection>ChangeLayer, and no Edit>Layers.

    Or maybe the problem is that, although I installed 0.26.1 this morning, the tool still thinks it's 0.25.8 according to the banner (and maybe is a mashup of some sort?). But I was also not finding the Change Layer or Edit>Layers in 0.25.8 on Ubuntu when I posted the original issue.

    Appears that the Windows Edit menu and the Ubuntu menu are quite different (I like the Windows version for its much (much!) more comprehensive function set, but I really want to work under Linux).

    Also attached a screen grab of the Windows 0.26 Edit menu pulldown w/ Selection expanded....

  • I tools like you started it in Viewer mode on Linux. No editing, no change layer .. :-)

    Either use "klayout -e ..." or configure the default mode as editor in File/Setup - Application/Edit mode.

    Matthias

Sign In or Register to comment.