Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

kLayout not starting on Mac after upgrade to 10.15 (Catalina)

Hello,

I have recently upgraded to the new Mac OS and can't get kLayout to start any more.
Initially it could not find the Ruby framework anymore, as that got updated in the new release. I could (presumably) resolve this issue after some search by pointing kLayout to the new framework location via

install_name_tool -change /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/libruby.2.3.0.dylib /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/libruby.2.6.dylib /Applications/klayout.app/Contents/MacOS/klayout

and

install_name_tool -change /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/libruby.2.3.0.dylib /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/libruby.2.6.dylib /Applications/klayout.app/Contents/Frameworks/libklayout_rba.0.dylib

However, now when starting kLayout, I run into

    Dyld Error Message:
      Symbol not found: _rb_cFixnum
      Referenced from: /Applications/klayout.app/Contents/MacOS/../Frameworks/libklayout_rba.0.dylib
      Expected in: /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/libruby.2.6.dylib

which I presume is due to an incompatibility between Ruby versions.
I obviously don't really know what I am doing here, any help appreciated.

Any idea for a fix?

Cheers.

Comments

  • Here is what worked for me. Basically installed Ruby 2.3.0 and linked Klayout to it as you did.

    1) Update Xcode through App Store

    2) Accept licence:
    sudo xcodebuild -license accept

    3) Install the Xcode Command Line Tools
    xcode-select --install

    4) Make sure it worked with brew:
    brew doctor

    5) Install RVM
    \curl -sSL https://get.rvm.io | bash -s stable --ruby

    6) To start using RVM you need to run: (!!!change USER to your username)
    source /Users/USER/.rvm/scripts/rvm

    7) Install ruby 2.3.0
    rvm install 2.3.0 --with-openssl-dir='brew --prefix openssl'

    8) Change Path to RVM installed ruby: (!!!change USER to your username)
    install_name_tool -change /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/libruby.2.3.0.dylib /Users/USER/.rvm/rubies/ruby-2.3.0/lib/libruby.2.3.0.dylib /Applications/klayout.app/Contents/MacOS/klayout

    install_name_tool -change /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/libruby.2.3.0.dylib /Users/USER/.rvm/rubies/ruby-2.3.0/lib/libruby.2.3.0.dylib /Applications/klayout.app/Contents/Frameworks/libklayout_rba.0.dylib

  • Thanks, a variant of that worked for me too, did not know about rvm..

  • Hi Mattiahalter,
    I wanted to install klayout on my Mac (OS Catalina) but it didn't work out due to the compatibility issues. So I followed your steps except for no.4 (brew doctor) which i simply typed in Terminal but command failed - I never worked with coding, so I am Alien at this planet :)
    could you please walk me through step 4? what i need to do to install Klayout successfully. Thanks.

  • Maybe you can join the discussion on GitHub here: https://github.com/KLayout/klayout/issues/381

    There are some links to installation files and I got some feedback these are working.

    Regards,

    Matthias

  • @Matthias, Great :) It worked out. Thanks a lot.
    Regards, Adnan

Sign In or Register to comment.