Marker Browser loaded with markers but will not show them


I was wondering if anyone else saw an issue where Marker Browser is loaded successfully with markers but will not show them (it shows all the details in the Browser window, bu will not present them on main window, nor will it zoom into them or do anything else).
This issue is on a specific PC with Windows x64 v0.26.4/5 installed. Other PCs including mine have no such issue.
I tried all options in the Browser Setup but they still do not show.

Thanks, Itamar


  • Maybe you should clear the configuration. If the issue is device specific, a damaged configuration is the only explanation I have.

    Delete or rename "C:\users\yourself\KLayout\klayoutrc" and try again.


  • Wondering whether this might be some discrepancy between the database that the markers were generated from, and the database called out to display them against?

    Seems peculiar that no "complaint" would be emitted, when you tried, if it is failing. But I have no good idea where such a complaint (perhaps informative) might be logged.

  • Hi Jim,

    Discrepancies can arise from cell names depending on the "Context" mode in "configuration" - some modes like "Marker database top cell" require cell names to match. In this case, the complaint is shown this way:

    Another case is a wrong location. With window mode "Fir marker" or "Center marker" the browser should you to the maker anyway, so you still should see it.

    A nasty pitfall is to have multiple markers selected and "Center marker" on. In this case, the center is the center of all selected marker's bounding box. With a sufficiently small zoom window, this might take you to a spot without any marker at all. Try to make sure you selected one marker polygon only if you have "Center marker".

    The same happens for "L"-shaped markers in case of "Center marker": then the browser takes you to the marker's bounding box center which may be outside the marker itself. Again, with a small zoom box the actual marker is outside your window. Try to zoom out in this case.



Sign In or Register to comment.