Windows10 - escape characters?

edited August 2020 in Verification

Trying to make my report go to a full-path file explicitly,
I encounter this:

It appears that the Windows backslashes are converted
to forward slashes, sort of, but something isn't working
out for that in the Win10 environment

Is there something like a need to "escape the escape"
in order to get file / folder traversal to wotk under


  • Hi Jim,

    There are two ways actually: single quotes or double backslash:

    > puts 'foo\bar'
    > puts "foo\\bar"

    There is a third option actually: on Windows, you will also be able to use forward slashes for the path separator. So "c:/your/path" should work too. It's just difficult to paste Windows paths then.

    Best regards,


Sign In or Register to comment.