Move Not Working

edited February 9 in Layout

I'm in the editor mode, with manhattan turned on. I have tried the simple select, move, click method (scales can be seen in the screenshot), and the result is it moved to ~-5000 μm.

Trying the move by method and inputting a y move of -16.0 μm moved it down to ~-8000 μm

Finally, doing the move to, again inputting -16.0 μm sends my selection to ~-9000 μm

In both cases doing a second move seems to delete the selection. Doing a zoom fit refocuses to (0,0) and there is nothing visible or selectable

Tried multiple times on 0.27 (school PC) and 0.27.7 (personal laptop)

Overall the goal is to import a few (6) .gds files and make a grid out of them, then save as .dxf. If there are suggestions for more efficient ways to do this even as a python script, I am open to other methods.

Comments

  • I have found the move, duplicate commands' action awkward,
    most especially the loss of selection if you don't click exactly on
    the selected item(s) - then that point is taken as reslect / deselect.
    It would be preferable to me if the selection before command, is
    "sticky" during repeats of that command (in fact, selection /
    deselection during a command, should be explicit (menu / bindkey,
    not a stray click) so that the selected set can be modified during
    the command's active duration (like, move and drop 1, move and
    drop another, ... within the "command stack"). Control-click
    (deselect) and shift-click (add-select) I would think OK as these
    won't "just happen". Missing a text origin, though, happens
    ALL THE TIME.

    Whether this has anything to do with OP's issues I have no idea.

  • @dick_freebird I see the point about loss of selection. I'll see what I can do here (-> https://github.com/KLayout/klayout/issues/994)

    @FizixMastr I think your problem is related to the understanding of hierarchy. You have probably selected shapes inside the same cell many times. So when you move the shape you are actually moving the shape inside that cell. So if you have selected the same shape multiple times, the same shape is moved many times and the effect accumulates.

    So you have to decide what you want to do. Either you just select the shape once in the cell and move it there - the effect will be that the shape will move everywhere else - or you move the cell, not the shape. I'd recommend the second option and use "Select top level objects" (View menu). This mode will prevent you from selecting something down in the hierarchy with weird effects.

    Matthias

  • edited February 10

    @Matthias It does work now. Thank you!

    Yes, there are 6 triangles in each unit cell. Perhaps, I've bastardized the software too much in this case, but if you have the time, I would be interested in the rationalization for the move function working like this.

  • The problem is not the move function. It simply does what it's supposed to: it moves the shape you selected within it's reference frame (the local cell). What you fight with are the implications of hierarchy. When you move a shape within the cell it will move in all other instances of this cell too and depending on the orientation of these instances the effects may be pretty unexpected.

    The "Select top level objects" mode guarantees predicable behaviour. But it will not let you select shapes from within the cells. Instead you move the instances itself, i.e. shift the cell placements. In the end that gives you the desired effect.

    Regards,

    Matthias

Sign In or Register to comment.