Problem with Layers Panel width in windows version

Hi Matthias-

Small but somewhat annoying issue:
On the windows version 0.26 & 0.27 the layers panel will sometimes get very wide and take a large portion of the monitor width. Any attempts to drag it to a smaller size fail.
For me on 0.26, when I start new Klayout window everything is OK, but if I load another design to a new panel then the layers panel becomes wide and is stuck at this wide size. Even if I close the additional panel it would not get smaller afterwards.
A peer of mine just installed 0.27 and it is starting a s a wide Layers panel to begin with.

Regards, Itamar


  • Not seeing this in my Win10 0.26.8 setup.

    Is this "stuck" behavior happening both when
    "docked" and "floated"? For me both seem to
    respond normally to drag-width. Maybe there
    is something about the "auxiliary frame" that
    holds the layers, navigator, et al that's got a
    bad idea about size and overrides individual
    windows that are snapped into it?

  • Hi dick_freebird-

    It's stuck for both docked and floated modes.
    Can you try opening two different designs in the same Klayout window but different panels and see whether it will get stuck?


  • I tried that before posting, I could not get the
    adjunct windows to "get stuck wide".

  • Isn't that the weird "mouse wiggling bloats window" mode of Windows?

    I don't see this behaviour too. Some Windows setting or a mouse problem maybe?


  • Aero Shake

  • Some more details on this issue:
    1. It's happening to few members of the lab here so I don't think it's a hardware/mouse issue
    2. We all use Windows10 x64 version in the lab
    3. I tested Klayout in Windows7 but do not see this issue (for both x32 & x64 versions)
    4. It is independent of the designs opened - I can see this issue just by starting new layout then another layout in a new panel
    5. When the issue happens, it is possible to make the Layers panel wider but it is not possible to make it narrower than a certain size

  • To Tracy's (tagger5896) remark, the "Aero" theme
    seems to be Win10 default but is meddlesome and

    I use a "custom" theme with all the dancing eggplants
    disabled, basic black background, etc.

    You might try stepping away from over-busy Win10
    defaults where they add no value, and see if that helps.
    Graphics acceleration settings are also worth a look.

  • Tried changing theme to a plain background color but still see the issue

  • Here's a blast from the past which talks about some
    windows (like Macro Development) doing a "focus
    grab" which then prevents a lot of things from working:

    Do you have any "startup" actions or "upon opening"
    actions scripted, which might be causing this problem
    to resurface? Could you maybe move aside, any init
    files (klayoutrc, invoked macro files) and replace with
    the minimal install versions, to see?

  • @mikamar One more thought: maybe there are high-resolution monitors involved?

    And if so: Could you trun running KLayout in one of the compatibility modes?



  • Tried running in compatibility mode - issue still exist

    I was able to get rid of the issue using the following sequence:
    1. unclick the 'load layers properties file' from 'default' and every other tech' node
    2. delete the layers properties entry from klayoutrc file ()
    3. starting\opening 2 layouts (in different panels) with no default layers properties file
    4. loading manually layers properties file for each panel

    If I now define default layer properties file for any tech' node and open 2 layouts, the problem is back.

    Maybe this can help resolve the issue. I'll try this sequence at another PC and will let you know

  • Verified on another PC - opening two layouts w/o default layers properties file will get rid of this issue

  • I see.

    So maybe you layer properties file contains some very long layer name - like a hundred characters? Or many blanks?

    The layer properties file is XML, so you can open it in a text editor and take a look.


  • Matthias-

    I use the same layers file for all designs.
    It does make the layers panel stuck when opening the first layout

  • I have a default .lyp asserted and autoload box checked,
    and opening two panels with two different layouts is not
    bothering my "adjunct windows" at all.

    Maybe you should post your working .lyp for inspection.

    Maybe uncheck the default-load and just use the
    "Technology" chooser to drive that bit of setup?

  • edited May 2021

    Hi Dick\Matthias-

    I can't share my lyp as it might be confidential, but I was able to replicate the issue with a dummy lyp file.

    Can you try the following:
    1. Create a dummy lyp file with multiple tabs, and long tab name for each tab (each tab can have just one layer inside)
    2. Set the default layer properties to the new dummy lyp file (the one with multiple tabs + long tab names)
    3. Close the Klayout session and start new session
    4. Start new layout. The layers panel with new dummy lyp will show but you should still be able to squeeze it to a minimal width
    5. Start new layout in a new tab. Now the layers panel will take large portion on the screen and you will not be able to squeeze it to a smaller width

    Thanks for our patience,

  • @mikamar You mean the tab names are very long? Maybe the problem is that all tabs want to fit in the layer panel. Could you confirm this?



  • Matthias-

    Yes, I noticed yesterday that the layers panel width gets stuck on a width that depends on the count of characters in all tab names.

    In the file I use regularly there are 10 tabs and each tab name is 6-7 characters long.
    But I can see the issue also in the dummy file where 1 tab name is few dozens characters long and the the other tab names are only 1 character long.

    Maybe it is possible to isolate the section in the code that when second layout is started in the new panel the code is setting the layers panel width based on the count of characters in all tab names.


  • I don't understand what "tab" means in this context
    but do observe that the minimum layers window
    width is the widest-field "name layer datatype" text.

    The Cells window seems not to have a displayed-
    width-driven minimum.

    If I Rename (right-click in Layers) and extend the
    name of one layer it does not affect the min width

    At this stage if I save the modified .lyp and load it,
    and load a new layout (same tech) into a new panel
    the min-width limit is unchanged.

    I'm having trouble making this modified .lyp "autoload"
    despite explicitly setting it in the technology window.
    It's indicated that this field overrides the technology-home
    .lyp , but seems not.

    I suspect the figuring of minimum width might be
    done during initialization, if indeed at all - it is not updating
    in real time nor on forced Load Layers.

  • Dick-

    You probably know that but just in case - if you want to set modified lyp file autoload you need to make sure only one session on Klayout is running, change the lyp file autoload in that session, close this session and only after you re-start new session the new lyp will autoload.

  • @mikamar This code is comes from Qt, so it's not in my hands.

    On Linux I can use as many characters in the tabs without impact on the layer panel's width.

    but also on Windows I don't see a problem:


  • edited June 2021

    Another thought in the vein of debug-slicing-the-problem -
    I know there are settings for what/how the layertable is
    displayed - you can, or not, show names / numbers / etc.
    I notice in Matthias' latest, the layertable window is not
    displaying any layer names, only layer / datatype, and
    maybe the issue lies in one of the not-displayed fields?

    Might try toggling those, or related permutations to see
    if you can toggle the problem, leading to a direction for
    fixing? Wouldn't surprise me if there were other "knobs"
    I don't know of, that pertain, either.

  • Good idea ... but does not make a difference :(


Sign In or Register to comment.